Site Search

Site Info

Home » Forums » Forum Archives » Disk Drives » Topic # 227

Compaq Bios/FDD
RobWhelton Oct-25-01 01:37 PM
I've just got an ex-office network Compaq Deskpro 4000, p-pro200. Arrived with an LS120 instead of a floppy which was great until it turned out to be dead as a dodo. Successfully formatted the hard drive and installed windows onto it by putting it inside another PC, then got the Compaq up and running and installed a CDRW. Problem arose when I replaced the LS120 with a normal floppy- thedisc accessing light comes on and stays on, from the moment I switch on the power to when I shut down. It spins when I put a disk in, but tells me the drive isn't ready. On bootup, it says 'system option not set'. I'm guessing that the Bios is set to look for an LS120 (on IDE) rather than a floppy. But pressing F10 won't let me into the bios to check this. Any tips? Getting quite desperate because I can only access the internet via my University's computers, which have only floppies, so I can't download software to help me.


1. RE: Compaq Bios/FDD
lbyard Oct-25-01 04:19 PM
In response to message 0
The cable is probably backwards... http://duxcw.com/faq/fd/fd.htm. Use the F10 key just when you see just a cursor in the corner of the screen (forget which one, but it is upper left of right). Pulling the keyboard may produce an error that will allow you to get into the setup. The setup is not in CMOS. It is in a maintenance partition on the hard disk drive (which is one of the reasons I really donít like Compaqs). Larry

2. RE: Compaq Bios/FDD
RobWhelton Oct-25-01 06:50 PM
In response to message 1
I've tried various combinations of which way round the cable goes... do you think the problem is due to me having low-level formatted the drive as soon as I got the machine? There doesn't seem to be another partition on it. Pressing F10 or holding down space bar to cause a keyboard error don't get me into the Bios.
Thanks for any help,


4. RE: Compaq Bios/FDD
lbyard Oct-25-01 09:32 PM
In response to message 2
I don't think that would make the floppy LED stay on. The floppy drive should be plugged into the very end of the cable, the end with the twist on most computers.

If it's an IDE drive it should not have been low-level formatted. That will destroy the partitions, including the maintenance partition, and may have actually ruined the drive. Or do you mean a DOS-level format of a partition (C:)? A:\>fdisk C: and display the partition info.

5. RE: Compaq Bios/FDD
RobWhelton Oct-26-01 02:17 PM
In response to message 4
Thanks for the info about the cable, you were right all along. I thought I'd tried every combination of which way round it would go, but obviously there was one left! Everything working hunky-dory now, thanks.
About the HDD- a friend of mine helped me set the PC up, and I heard him mention something about low-level formatting. Now that you mention it, I do recall from my Amiga days that this would destroy an IDE drive, and that it was only for SCSI use. Seeing as the drive works fine, he presumably didn't LLF it, then. But I still can't get into the bios. It would make sense that this was due to formatting the HDD (I can't see any other partitions on it), but if I had no bios the PC wouldn't work, would it?

6. RE: Compaq Bios/FDD
lbyard Oct-26-01 05:45 PM
In response to message 5
I don't see how it is not see partitions on it if the drive works, unless you have EZ-drive, etc. on it for large drive support and you are booting to a floppy without first being prompted to press the space (?) key. If that is the case, donít put the floppy in until prompted. Larry

| Home | Guides | How to | Reviews | Online Store | FAQ | Forums | Forum Archives |
| Links | News | Newsletter | About Dux | Advertising | Contact Info | Privacy |