Site Search

Site Info

Home » Forums » Forum Archives » Other Computer Problems » Topic # 97

modem not recognized
diletante Dec-12-00 02:41 PM
I recently upgraded a machine to an Abit KT7 motherboard and Athlon. The case was also replaced, as was the sound card. The machine has been up and running for 3 or 4 weeks.

Last week the old Supra 56K ISA modem seemed to fail. For a while, even before the upgrade, the modem would hang occaisionally. It failed to reset for AOL, Hyperterminal could not access it, and the Contol Panel/Modems diagnostic couldn't communicate with it. It would reset if the computer was powered down, but last week even that wouldn't work.

I tried re-installing the modem, both in Windows 98 and by physically removing it and starting from scratch. Windows could not detect it. Nothing worked, so it seemed like time to retire it.

I bought a new USR 2977 OEM modem. Note that I bought a PCI modem instead of an ISA like the old one. The installation went fine. Windows detected the modem, and I directed it to the driver. The modem showed up on COM5. I fired up AOL and started to log on. The modem dialed and I smiled -- too soon. The connection was not completed. AOL could not access the modem to redial. Control Panel/Modem diagnostics could not communicate with it. Shutting down didn't help.

Here is the interesting part. I have tried several times to reinstall the modem. Windows sees an unknown PCI serial controller, but not a modem. Efforts to direct Windows to the correct driver for the modem fail. Similarly, if I skip trying to install the unknown device and go to Control Panel/Modems to try to install the modem, Windows can't find the modem. If I persist and try to manually install the modem, I get to the point where you select "Have Disk" and then browse the floppy with the drivers on it (tried 2 different disks, latest drivers). You can see the drivers on the disk, but when you click OK, an empty dialog box results. There are no selections to choose from for the driver/modem. It doesn't matter if the phone line is plugged in. Control Panel/Add Hardware locked up the computer when I let it search for new hardware.

My conclusion is that the computer no longer recognizes the modem as a modem. It is probably crippled/broken but has enough functionality left to appear as a PCI device. I think the modem smoked but hope I am wrong.

If the board smoked, there are 2 suspects: the phone line, and the computer. The phone line works. There are 3 other modems using it, and you can call out on voice. This particular connection is routed through a surge protector that is included in a power strip, otherwise it is the same as the other connections. The voltages in the computer are OK according to the BIOS. There are 4 other PCI boards in the machine, and they aren't smoking. The first modem was an ISA board, and it probably suffered the same fate as the new one. Finally, the first modem seemed to be having problems for a while before the computer upgrade.

I'm going to measure the voltages on the phone line after it leaves the surge suppressor, and the modem can be tested in another machine. What am I missing?


1. RE: modem not recognized
lbyard Dec-12-00 04:54 PM
In response to message 0
Rob, Yes, I have seen this problem quite a few times and the new MODEM could be bad. First, try deleting the MODEM and all COM ports in the Device Manager and rebooting . To isolate the problem, I would test MODEM on another computer. Also, on occasion, I have had to manually remove all of the MODEM drivers, etc. and registry entries and reinstall to get a USR MODEM working. USR/3COM has (or had) a procedure for doing this on their web site and I have found in some cases that that was the only thing that would fix the problem. Larry

2. RE: modem not recognized
diletante Dec-12-00 05:23 PM
In response to message 1
Hmmmm. Manually removing all the modem drivers and registry entries sounds tedious. At least there is hope. Thanks. Rob

3. RE: modem not recognized
lbyard Dec-12-00 06:27 PM
In response to message 2
It's not one of favorite things to do. Larry

4. RE: modem not recognized
diletante Dec-18-00 02:21 PM
In response to message 3
Additional information and a new question:

One of the advantages to having too many PC's is that you can tolerate a broken PC for a while. Last week was a busy week at work, so I didn't have much time at home to work on this modem problem. However, I acquired a phone line tester to check the line and put it to use this weekend. It turned out that the line polarity was reversed at the service entrance on the phone company side. (Interestingly the phone company thought it was my fault and warned me of the service charge if they sent out somebody to fix it.) The expedient thing to do was to cross the wires on my side - which I did.

After the polarity problem was corrected, my other 2 PC's are getting much better connection speeds. The line voltage is good, so now I don't have a phone line problem, but I still have either a computer that can't recognize a modem or a blown modem.

The USR modem that isn't working hasn't been swapped to another machine to test it, but I don't think the line problem was sufficient to smoke the modem, unless I am just very unlucky. It is my understanding that a reversed line will affect performance, but that it will not damage a modem. I'm told it does increase the risk that a transient (like from a nearby lightning strike) will kill the modem.

Based on Larry's advice I spent some time looking for problems in the Registry. There are references to the previous Diamond Supra modem under HKEY_LOCAL_MACHINE\Enum\MODEMWAVE. I was tempted to delete the whole branch from MODEMWAVE on, but the registry is new territory for me. I backed it up and decided to seek advice. Should MODEMWAVE be deleted? Larry, you also mentioned deleting drivers by hand. How can I find stray modem drivers in order to delete them?


5. RE: modem not recognized
lbyard Dec-18-00 04:14 PM
In response to message 4
Rob, I would run regclean: http://support.microsoft.com/support/kb/articles/q147/7/69.asp. Larry

6. RE: modem not recognized
diletante Dec-20-00 01:49 AM
In response to message 5
I ran regclean tonight. It didn't take very long, and I couldn't detect any changes to the registry. I also verified the comm port drivers in Windows by reloading them from the CD as suggested by a MS knowledge base article. Finally, I editted the registry to remove the WAVEMODEM HKEY entry and all its sub-branches.

Nothing helped. Finally I deleted the com ports and mystery device in system manager and did one last reboot. No joy. It is starting to look like the modem may be the culprit. I will have to pull it out and try it in another machine. It isn't very enticing to try to put it in a other machine, since they are all getting heavy use right now. Maybe I will do it on Friday, after school is out.

I am open to any new ideas.


7. RE: modem not recognized
lbyard Dec-20-00 05:58 PM
In response to message 6
Reseat the modem.

Try another PCI slot.

Change the memory range of the MODEM in the device manager.

Perform the three-finger salute (hold Ctrl and Alt and press Delete--do onec, only) to pull-up the Task Manager window and close all non-Windows essential programs, including screen savers, antivirus software, system monitoring software, etc.?

Pull all boards except the MODEM and video.

I tried to find that uninstall documentation 3com' site again today without luck. That fixed the problem in several cases.


8. RE: modem not recognized
diletante Dec-20-00 08:30 PM
In response to message 7
Ok, I can try all of that except for changing the modem resources, since it doesn't show up in the system manager and has no resources. I have found another person with the same symtoms and also someone with the same modem working in a KT7. That is progress!


9. RE: modem not recognized
diletante Dec-22-00 06:04 PM
In response to message 8
Got an RMA. The modem has the same problem in another machine. I should have tried it sooner.


10. RE: modem not recognized
stevehenry Dec-28-00 03:10 AM
In response to message 9
I have run into a similar problem with my diamond supramax. there is a trick to installing pci modems. first you may have to install the modem emulator. you go to ADD HARDWARE, and select ?OTHER. let it find that off your installation disk. Then install the modem. I tore my hair out before i found this trick on the website--it was NOT in my instructions

11. RE: modem not recognized
diletante Jan-01-01 02:21 PM
In response to message 10
SteveHenry, Thanks for the information. I think I tried all combinations of installation approaches a few times with this one, but your information may help yet. My son also has a 2977 and after reinstalling Win'95 last week, the modem was difficult to install, and the machine doesn't seem satisfied with the PCI boards. Even though all the hardware is installed and working, it finds a new PCI device at every startup and carries one or two entries under ?Other. Maybe I will try removing the modem and reinstalling. (After all the trouble with modems, that will take some nerve.)

How long do we have to wait before plug-n-play really works? Rob

13. RE: modem not recognized
lbyard Jan-01-01 03:01 PM
In response to message 11
Rob, Plug ‘n Prey will probably be with us until those in power realize that most of us would prefer things that work well more than 2 GHz processors, 80 GByte hard disk drives, and operating systems and word processors with more bells and whistles than most of us have time to learn how to use. Larry

14. RE: modem not recognized
stevehenry Jan-02-01 04:08 AM
In response to message 13
actually, there are several devices to be installed with the pci modem. there is the emulator, modem, wavetable and i believe a sound device. makes installion difficult. i have also had it installed and it still wouldn't work because for some reason it didn't like comm port it was on. on my old HP i actually had to have the modem installed TWICE on two different comm ports to get it to work. the machine didn't like the first comm port plug n play selected. I then had to select in dialup which modem it used, modem or modem#2. since it worked, i left it alone. Kircheff's Law--If the da** thing works at all-leave it alone!

15. RE: modem not recognized
diletante Jan-22-01 01:21 PM
In response to message 14
Here is a followup for anyone who tried to keep up with this thread. The vendor tested the modem I returned and said that it worked, but they replaced the modem anyway. Last night I installed the new one without any trouble at all. Hmmmm.

Next time I won't be so slow to call for a RMA.


16. RE: modem not recognized
Tim ;o) Feb-26-01 02:32 PM
In response to message 15
I’ve got a SupraExpress 56i Internal and I constantly get; ‘modem not responding’ or ‘port in use’ or ‘port already open’. I’ve searched all over the web and done all the recommended things I can find, including everything in this thread; reversed the telephone connecting wires etc… Every day for the last two weeks I’ve spent some time trying to solve the problem.

The only thing I’ve found that lets me connect is; ctl, alt, delete once and close Rnnaap then from ‘modem properties’>Diagnostics> select modem, click ‘more info’ and hey presto the modem usually then works. It’s a pain though as I have to go through this rigmarole every time I want to connect. I’d love to be able to get the damn think working as it used to…I haven’t installed anything new to cause the problem; just moved from one house to another … any ideas?

Tim ;o)

17. RE: modem not recognized
lbyard Feb-26-01 02:54 PM
In response to message 16
This is usually caused by another program that is loading at startup and is using the same COM port as the MODEM. Start, Run, msconfig or msconfig32 and disable all start-up programs except ScanRegistry, SystemTray, LoadPowerProfile, and TaskMonitor. It may be a program that is being started by a RUN line in the Win.ini file. Larry

18. RE: modem not recognized
Tim ;o) Feb-27-01 06:11 AM
In response to message 17
Hi Larry

Thanks for the advice.

I can’t seem to locate a com port problem, the modem is on port 3. I only use port 1 for a mouse and have disabled port 2. Device manager only shows com ports 1 & 2 (also lpt1 & 2 obviously) although Win.ini lists COM ports 1,2,3 and 4. I haven’t a clue what port 4 is being used for (if at all). It’s listed as 9600,n,8,1,x so I don’t think it’s conflicting with the modem, I also tried disabling it to no avail.

I ran msconfig and did as you suggested, no luck unfortunately… I’ve also looked closely at Wini.ini and can’t see anything that might be causing a problem but then again I’m no ini expert!

As an aside, after disabling Norton in startup I had what looked like the KAK virus (a window opened at startup). I ran the virus checker and it found three infected files in the recycle bin, unfortunately I had a power cut before I could finish and was forced to shut down before the ups ran out.

I checked for the tell tale signs of KAK in the registry and Outlook but could find nothing. I did find an entry for KAK.hta in startup, maybe it wasn’t removed after I cleared the system of the virus last year. I’ve since deleted all files in the recycle bin, should have done it a long time ago!

I’ll run the virus checker again but as it takes a couple of hours I need to be sure I’m not going to experience another power cut; always a bit of a problem here in Greece.

It was a long session last night, so many reboots…

All suggestions gratefully received, thanks

Tim ;o)

19. RE: modem not recognized
lbyard Feb-27-01 02:10 PM
In response to message 18
The run line is in the section of win.ini. I wouldn’t worry about the rest of win.ini. COM3 and COM1 usually use the same IRQ, IRQ4. Try deleting all COM ports in the Device manager and going into the CMOS Setup and setting IRQ4 to ISA/Legacy. That may push the MODEM to COM2: Larry

20. RE: modem not recognized
Tim ;o) Feb-27-01 07:58 PM
In response to message 19
Well, where do I start?… I did as you suggested Larry, even though I was a little apprehensive about deleting the COM ports, especially as my rodent resided on COM 1.

Ha ha ha, reinstalling software and navigating when Windows refuses to recognise all COM ports is fun isn’t it? ;o)

Even without the rodent I was faced with yet more problems…there were conflicts conflicting with yet more conflicts, things went a little weird to say the least! The machine even tried to install drivers for something identified as: CP’’’Ap’AB, what ever that is???

To cut to the chase… the modem now resides on COM 4, IRQ5…you wouldn’t believe the number of installations and reboots I had to endure to even get the machine to recognise a working modem at all. It insisted on putting it one COM 1 together with the mouse with obvious results. The only way I could get around that was to install yet another instance of the modem and later delete the offender, reinstall the drivers, yet again etc etc. There were even more strange things happening but I expect your eyes are glazing by now… I know mine are after yet another long battle…

The result of all this? Exactly the same problem, back to square one!!!

I’m sorely tempted to give up and resign myself to manually setting up each time I want to connect (as mentioned before), it’ll probably be quicker than spending any more time on this pig of a pc. I have two other fairly well behaved machines but then I don’t use them for the Internet.

What can I say? Thanks for your suggestions….what’s next?


Tim ;o)

PS Oh, I nearly forgot… I did manage to run the virus checker again this morning and I am pleased to report no infection, just one file found in quarantine. And the run line in win.ini pointed to nothing…

21. RE: modem not recognized
lbyard Feb-28-01 02:31 PM
In response to message 20

“(17712) - I get a `Can`t open port` error message when running the More Info test on my internal modem.
There are several possible causes for the `Can`t Open Port` error message:

1) Another program is running in the background, preventing the modem from being queried. Close down all programs before proceeding.

2) The modem is in conflict with another device. Try changing the COM port of the modem in Device Manager.

3) The default communications driver is not set properly. In Windows, go to Start>Run, and type in sysedit. In the system.ini file under the section, make sure comm.drv=comm.drv, not another file.

4) In c:\windows, rename telephon.ini to telephon.bak. Go to Start>Run, and type tapiini.exe. This will rebuild telephon.ini, and may resolve this.”

22. RE: modem not recognized
Tim ;o) Feb-28-01 04:06 PM
In response to message 21
Thanks for your patience Larry.

Diamond was (obviously?) my first port of call and I went through their suggestions some time ago.

Over the last two weeks I’ve had the modem on just about every combination of COM port and IRQ that exists. I’ve been involved with computers since BASIC on a ZX81 and I don’t like to admit defeat but this problem has got me, and it would seem you and several others, beaten.

I’m going to have to give up, it’s taking far too much of my time and I have more pressing problems with my music computer…##### ASIO drivers! I’m resigned to having to go through diagnostics every time I want to connect; unless you hear of anything new...

Thanks once again

Tim ;o)

23. OT RE: modem not recognized
Tim ;o) Feb-28-01 04:10 PM
In response to message 22
I’m surprised a simple four-letter word beginning with D and ending with N gets that sort of treatment!

Tim ;o)

24. RE: OT RE: modem not recognized
diletante Feb-28-01 07:00 PM
In response to message 23
Just got a minute to look back at this thread and see where it has been heading. Interestingly, the reason I bought the offending USR modem (that was the cause for the original post) was because my SupraFAX modem 56i was behaving just as described by Tim! I got tired of that problem quickly, since that modem never got connect speeds as good as the USR modems I am using elsewhere. So, my fix for the problem was to replace the modem. Rob

25. RE: modem not recognized
Tim ;o) Feb-28-01 07:13 PM
In response to message 24
LAST EDITED ON Feb-28-01 AT 07:15 PM (GMT)

Thanks for that diletante, looks like I’m headed in the same direction…

Tim ;o)

26. RE: modem not recognized
Tim ;o) Mar-04-01 07:12 AM
In response to message 25
LAST EDITED ON Mar-04-01 AT 07:13 AM (GMT)

Problem solved!!! Not in the best way admittedly (maybe the only way possible?) but at least I now have a working connection.

I bought a 3Com U.S. Robotics external (5630). Not only does it work each time it also connects at the highest rate I’ve seen on our poor quality line (33,333) much faster then the old Diamond one, when it worked!

The Diamond 56sp int is going in the bin, I just wish I’d done it ages ago!

Thanks again Diletante.

Tim ;o)

27. RE: modem not recognized
flane Mar-26-01 09:01 PM
In response to message 26
I had a "modem not recognized" problem installing a USR 5699A 56k modem. The install disc included in the package did not have the install software. It seems that this software runs a program that yanks modem info out of the registry.

The registry contains "cooties" left over from the last PnP modem (in the words of a USR tech support). Her supervisor helped me extract a 98se executable and a USR file (usrinst.exe ?) that removed the "cootie". With a clean registry and completely unistalled modem, the computer finaly recognized a new modem and installed the drivers (that I had to download because of the install disc mix-up).

Try pursuing that angle to resolve the "modem not recognized" issue.

| Home | Guides | How to | Reviews | Online Store | FAQ | Forums | Forum Archives |
| Links | News | Newsletter | About Dux | Advertising | Contact Info | Privacy |