Site Search

Site Info

Home » Forums » Forum Archives » Other Computer Problems » Topic # 37

OpenComm "Couldn't open port"
Stevelee Aug-01-00 07:58 PM
Hi Larry and everyone.
I have been trying to install a modem for a friend, on a Win95 PC.
There is a mouse on COM1, and I have been trying to get the modem to work on COM2.
All I can get is an error message box, headed "OpenComm", with the message "Couldn't open port" when I try running the modem diagnostics from Control Panel.
I have exhausted all my possibilities trying to get it to work - can anyone give me any clues, please?

1. RE: OpenComm
lbyard Aug-01-00 08:38 PM
In response to message 0
LAST EDITED ON Aug-01-00 AT 08:40 PM (GMT)

What kind of MODEM is it? ISA or PCI? Make and Model? The message indicates that Windows has tried to use the port and something else is already using it. I've seen these problems before. Some are easy to solve, others are difficult. First, be sure COM2: is ddisabled in the motherboard CMOS Setup. Try to delete COM2: in the Control Panel, Device Manger, reboot, and detect hardware. If it is a 3-COM/USR MODEM, the problem can be more involved. Larry

2. RE: OpenComm
Stevelee Aug-01-00 09:12 PM
In response to message 1
Hi Larry.
Thanks for the repply. I will see what I can find out about the modem. I know it is an external model, using the Rockwell chipset according to the box. I don't recall its actual name - it was one I hadn't come across before.
I have tried removing COM2 and any modem from the system via device manager, and then reinstalling them.
I never managed to get the system to recognise the modem on boot up, after removing it via device manager and rebooting.
If you have any further thoughts before I try again tomorrow evening, they would be appreciated.
Best Regards,

3. RE: OpenComm
lbyard Aug-02-00 03:58 PM
In response to message 2
I should have thought of the possibility of an external MODEM. I normally do not recommend them because they add more variables when troubleshooting (and have more things that can break), cost more, and take-up desk space. The first thing I would check would be the cable. Some external MODEMs require a MODEM cable, and there variations of MODEM cables, and other MODEMs use a straight-thru RS232C serial cable. The only way to be certain that you have the correct cable is with a pin-out of the MODEM or a cable diagram. Most MODEMs have LEDs on them to help with diagnosing problems. An RS232 break-out box is another useful tool and should be in every computer shop. The reference book I use is Data Communications for Microcomputers, With Practicable Applications and Experiments, Elizabeth A, Nichols, Joseph Nichols, Keith R. Musson, McGraw Hill, 1982. Keith gave me a copy of the book many years ago and I have not seen a better book on the subject for use in a shop. Larry

4. RE: OpenComm
Stevelee Aug-02-00 07:17 PM
In response to message 3
Hi Larry.
Thanks for the thoughts. I don't think that it is the cable somehow - apparently he modem was working fine until the Dad in the family decided to 'clean lots of things off and start again' as his daughter put it. It is still using the same cable.
I was going to try swapping the mouse and modem round on heir respective COM ports, but they are using a PS2 mouse via a 9-pin adaptor, and I didn't have a suitable adaptor to hand to try plugging the mouse in to the 25 pin port.
One suggestion that I had was that there might be too many phones on the line ( we are stuck with a REN of 4 per line here in the UK - I don't know if you are similarly afflicted in the States ). However, they assure me that they only have the same number of phones now as when it was working properly.
It will be Sunday now before I get back there, so if you have any further thoughts, I'd be interested.
Thanks again,

5. RE: OpenComm
lbyard Aug-02-00 08:50 PM
In response to message 4
I don't think it being caused by the telephones either. Windows is having a problem using the COM port and that is on the other "side" of the MODEM/chip(s) from where the phone line is. You might try disabling all statup programs. Run msconfig and disable startup, win.ini windows run load, autoexec.bat, config.sys, etc. Larry

6. RE: OpenComm
diletante Aug-04-00 10:00 PM
In response to message 5
I just had time to skim this thread, but I think I read that you have tried disabling COM 2 and that you are trying to install the modem there. Since the modem is external, you need the COM port working. Do not disable it in the BIOS or in the Device Manager. Make sure it has resouces that are not in conflict.

I hope this helps, because I didn't read the whole thread before answering. If I am off base, sorry for the noise.


7. RE: OpenComm
Stevelee Aug-05-00 07:57 AM
In response to message 6
Hi Rob.
Thanks for your input. What I had actually done was remove the COM2 port and any modem from device manager, power down, reboot and reinstall first the COM 2 port and then the modem.
I realise that the com port needs to be there for an external modem to work.
Thanks anyway,

8. RE: OpenComm
BigJohnnyP Jul-12-01 05:07 PM
In response to message 1
Had this problem ever been resolved? I'm having the same problem now myself.

I'm using a 3COM/USR internal modem. It was mentioned that fixing USR modem problems is more involved?

The funny thing I noticed is even after I delete all COM ports from device manager, it still lists COM1 twice in the modem properties/general/port dropdown.

Also, following the advice in the Win98 troubleshooter, I used debug and typed d40:0 to list the COM addresses, and it showed all zeros.

Any suggestions?


>AT 08:40 PM (GMT)

>What kind of MODEM is it?
> ISA or PCI?
>Make and Model? The
>message indicates that Windows has
>tried to use the port
>and something else is already
>using it. I've seen
>these problems before. Some
>are easy to solve, others
>are difficult. First, be
>sure COM2: is ddisabled in
>the motherboard CMOS Setup.
>Try to delete COM2: in
>the Control Panel, Device Manger,
>reboot, and detect hardware.
>If it is a 3-COM/USR
>MODEM, the problem can be
>more involved. Larry

9. RE: OpenComm
lbyard Jul-12-01 06:21 PM
In response to message 8
Read the readme.txt file in \Drivers\Modem\3com- usr\Winmodem on the Win 98 CD. Please let us know if it helped you fix the problem. I'll be unhappy if you don't. Larry

| Home | Guides | How to | Reviews | Online Store | FAQ | Forums | Forum Archives |
| Links | News | Newsletter | About Dux | Advertising | Contact Info | Privacy |