Site Search

Site Info

Home » Forums » Forum Archives » Networking and Internet Sharing » Topic # 872

ICS still doesn't work
FC Apr-25-01 09:20 PM
I know a lot of people ask this kind of question 'cause I've been reading it but I still can put that thing to work.
I have win98se in two computer and one ADSL conection to Internet, I read the How to... for intall ICS but it didn't solve the problem. Then I tried with Microsoft Knowledge Base I've downloaded and read a lot of things...
I can ping client from host and host from client, I know DHCP is working because I've seen the client with it's IP, I can ping the ADSL Modem, but I can't ping any internet direction from the client (I can ping from the Host).
I have the gateway set to in the client.
I just don't know what to do, do you have a clue?


1. RE: ICS still doesn't work
lbyard Apr-26-01 03:42 PM
In response to message 0
Can you ping Larry

2. RE: ICS still doesn't work
FC Apr-26-01 07:54 PM
In response to message 1
>Can you ping Larry

Thanks for your reply Larry. I can ping from de host but the client says wait time over.

3. RE: ICS still doesn't work
lbyard Apr-26-01 09:33 PM
In response to message 2
LAST EDITED ON Apr-26-01 AT 09:33 PM (GMT)

I understand that Client can ping the ADSL MODEM, but not a host on the Internet. Is that correct? Do the Shared and Home components of ICS correspond to the correct adapters in the host?
TCP/IP(Shared)->ADSL adapter
TCP/IP(Home)->Network Adapter
Exactly what are the network configurations on both computers?

4. RE: ICS still doesn't work
FC Apr-27-01 04:17 PM
In response to message 3
That's right, I can ping ADSL modem from the client but I can't reach internet.

The configuration are this:
Microsoft Network client
Telephone access adapter
VPN adapter
ICS adapter
Realtek RTL8029(AS) PCI Ethernet NIC (1)
Realtek RTL8029(AS) PCI Ethernet NIC (2)
ICS (protocol) -> ICS
ICS (protocol) -> Realtek (1)
ICS (protocol) -> Realtek (2)
NDISWAN -> VPN adapter
NetBEUI -> Realtek (1)
TCP/IP (shared) -> Realtek (2)
TCP/IP (home) -> Realtek (1)
TCP/IP -> Telephone access adapter
Printer and files share for MS network

Microsoft network client
Telephone access adapter
E200plus Series PnP Ethernet Adapter
NetBEUI -> E2000plus
TCP/IP -> Telephone access
TCP/IP -> E2000plus
Printer and files share for MS network

Both computer were using dial-up access.
I had to translate the names from spanish so maybe some are wrog but you know what I meant.

I really apreciate your help Larry, tnx.


5. RE: ICS still doesn't work
lbyard Apr-27-01 06:45 PM
In response to message 4
I would try removing the dial-up on both computers and VPN on the host. For your information, TCP/IP can be bound to a maximum of four adapters. If that doesn’t fix it, could you send me the TCP/IP parameters? I am bewildered by the fact that the client can get past the NAT but not to the Internet. You haven’t tweaked the TCP/IP parameters in the Windows registry, have you? Larry

6. RE: ICS still doesn't work
FC Apr-27-01 10:55 PM
In response to message 5
I've tried use winipcfg to see what's going on and I can release and get IP from the client, so I think DHCP is working. Also I see a check mark on IP routing on winipcfg window on both, client and host, is it ok?
I've removed all adapter but the ethernet from the client, but when I take off telephone adapter from de host it was unable to dial the conection to internet.
I know that the adapter are in the right way 'cause I check its ip ( ADSL and LAN) the only thing I don't understand is that the tcp/ip (shared) has a dinamyc ip and the tcp/ip bounded to ICS has the ip that was on tcp/ip->ethernet ADSL.
All I did with the registry was to add "(1)" "(2)" at the end of the ethernet card so I can diferenciate them.

7. RE: ICS still doesn't work
lbyard Apr-28-01 04:15 PM
In response to message 6
I installed ICS this AM to check and ICS does check the IP routing. What versions of Windows do you have installed? Are you logging into Windows or the Microsoft client on the client computer? ICS will not work unless you log in on both computers.

A possible clue… MS KB Q234773 (http://support.microsoft.com/support/kb/articles/q234/7/73.asp)
“Establishing a VPN connection on the ICS Host modifies the Routing Table on the ICS Host and forces all clients that try to connect to the Internet to use the VPN routing table instead of the routing table used to connect to the Internet service provider (ISP). This can create the following issues:
Clients may not be able to resolve the names of Internet resources and must use the Name Resolution services of the network where the ICS Host is connected using VPN. In Microsoft Internet Explorer, client computers may receive the following error message: Error: Page Can Not be Displayed…” Larry

8. RE: ICS still doesn't work
FC Apr-30-01 03:33 PM
In response to message 7
I'm using win98se on both computers, when I turn on the computer (both) I have to write user name and password (I don't know if that anser your question about log in both computers)
I've read the MS KB article but I don't know exactly what it means, can I use ICS with VPN and ADSL?
Thanks for your help Larry.

9. RE: ICS still doesn't work
lbyard Apr-30-01 05:02 PM
In response to message 8
I haven't used VPN. You need a VPN server to use it. I presume from the Knowledgebase article that it can be done. But, as I said before, I would remove VPN while troubleshooting ICS. A basic precept in troubleshooting hardware and software problems is well stated in the KISS principle. Larry

10. RE: ICS still doesn't work
FC May-02-01 03:17 PM
In response to message 9
I'm not shure but I think I need VPN to have access to my ISP, actually, when I created the conection to access to Internet I used the VPN adapter instead of modem.
Anyway I'll try to take it off and see what happen.

11. RE: ICS still doesn't work
FC May-07-01 09:07 PM
In response to message 9
Larry, I'm sorry but I have one more question.
Now I can use ICS but the point is that I set Internet Adapter on ICS Options to telephone access.
I think that could be because I'm using a telephone conection but instead seting it to the modem it uses a VPN Adapter and dial the ADSL modem's ip.
what do you think?

12. RE: ICS still doesn't work
lbyard May-08-01 03:43 PM
In response to message 11
LAST EDITED ON May-08-01 AT 03:45 PM (GMT)

Now I'm confused... I don't understand why you have vpn installed and it's relationship your Internet conection. Larry

13. RE: ICS still doesn't work
FC May-08-01 08:03 PM
In response to message 12
Maybe this can give you a clue. When I installed my internet account I had to add VPN to my PC because when I connect to my ISP I use a telephone access conection wich dials my ADSL Modem IP. That's why I think internet conection goes throught Telephone Adapter and then VPN using the NIC attached to the ADSL modem.
I don't know if it is that way but now it works.
The settings on ICS are Telephone adapter for internet and NIC for LAN (the one that is connected to the local network).
Thanks for your time Larry.

| Home | Guides | How to | Reviews | Online Store | FAQ | Forums | Forum Archives |
| Links | News | Newsletter | About Dux | Advertising | Contact Info | Privacy |