Site Search

Site Info

Home » Forums » Forum Archives » Networking and Internet Sharing » Topic # 841

I'm must be missing something simple for NetBEUI
ahcarte Apr-16-01 00:46 AM
Trying to network the computers in the house. Eventually will be 6, but for now just trying to get two to talk. I have gone through the “How to network” instructions many times. The configurations are the same on all computers. I have tried to get several different pairs of computers to talk. I am also using a Netgear DS108 (autosensing 10/100 hub). These network cards are also autosensing 10/100. The cards pass all the diagnostics for both hardware and network. Included in the diagnostics program is the ability to set one computer as a master and the other as a slave, and they spew some form of packet data (740 bits x1000) back and forth at each other over the network. This works fine on any two computers on the network
A side note here. This works when I use straight through cables via the hub. If I try and use a crossover cable, this diagnostic fails. Some packet data appears to be transferred, but only about a third. There are many dropped packets and errors. ALL of the cables are cables I built following the instructions VERY carefully. I have rebuilt the crossover three times, and borrowed one from work all with the same results. Hub ok, crossover not. At any rate, since the diagnostic program provided, successfully passes data between any two machines on the network using straightrhoughs (which I built also), I am assuming the hardware is ok.

Oh yeah, Win98SE on all computers. Tyan Trinity AT motherboards, AMD K2-450, 128 MB RAM. Yes I have the IRQ routing patch for the VIA chipset. Had to get that installed for something else somewhere along the way. I have all up to date W98 updates installed.I have tried removing and reinstalling all network components rebooting in between. I have tried renaming the computers and changing to different workgroup names. (Yes I always make sure they are on the same workgroup.)I was going the NetBEUI route first because it was supposed to be easy???

What happens: Boot up. Get the Logon screen. It doesn’t seem to care what I enter on the logon screen. Windows comes up. Go to explorer and expand network neighborhood. Hour glass for 5-15 seconds and then it opens and shows “Entire Network” and sometimes the local computer, which I can expand and show the shared resources for the local machine. Hit refresh. Nothing much happens. Right mouse the Network Neighborhood and do the “Find computer” thing.. double backslash and other computer name. “0 computers found”. Go to command prompt and type “net view /workgroup:LOCAL and get only the local machine:
Servers available in workgroup LOCAL
Server name Remark
The command was completed successfully.

The above behavior is the same on all computers. What am I missing?

Client for Microsoft Networks
Dial-Up Adapter
NEGEAR FA311 Fast Ethernet PCI Adapter
NetBEUI -> NETGEAR FA311 Fast Ethernet PCI Adapter
TCP/IP -> Dial-Up Adapter
File and printer sharing for Microsoft Networks

Primary Network Logon = Client for Microsoft Networks
File and Print Sharing is enabled on several directories

MS Client
Logon validation not selected
Network logon options -> Logon and restore network connections

Driver Type->Enhanced node 32-bit…
Advanced->Enable p2p IP = YES
Advanced->IP Packet Size = Automatic
Advanced->Record to log file = no
Advanced->Use IPX header compression = yes

NETGEAR FA311 Fast Ethernet PCI Adapter
Driver Type->Enahced 32-bit…
Advanced->Network Address->Not Present
Advanced->Network Media = Autosense
Advanced->RxBuffer Count = 40
Advanced->TxBuffer Count = 40

Bindings->Client for MS Networks
Bindings->File and Printer Sharing
Advanced->Maximum Sessions =10
Advanced->NCBS = 12
Set this protocol to be the default protocol NOT selected

IP Address->Obtain IP address automatically
WINS Configuration->Use DHCP for WINS
Gateway -> Blank
DNS Configuration->Disable DNS
Bindings-> NONE
Advanced->Allow Binding to ATM = No
Advanced->Set this protocol to be the default protocol IS selected
NetBIOS->over TCP/IP NOT selected

File and Printer Sharing
Advanced->Browse Master = Automatic
LM Announce = No

Computer Name = ARTHUR

Access Control = Share level access control


1. RE: I'm must be missing something simple for NetBEUI
ahcarte Apr-16-01 03:56 AM
In response to message 0
I have since managed to swipe a couple of known to be good straight through cables from work. No change. I also got a copy of the home networking wizard off of a windows ME computer and tried that too. No joy.

Tried the static ip route too. Each computer can ping itself just fine but not the others.

2. RE: I'm must be missing something simple for NetBEUI
lbyard Apr-16-01 02:01 PM
In response to message 1
The crossover cable is probably bad. Are you using the correct RJ-45 plugs for the kind of wire you using for the cable. The plugs should be rated for CAT5 of 5E and should be for stranded or solid wire, depending on the cable. Some plugs will work with both kinds of wire. The cable should be rated CAT 5 or 5E. If it is, it will have CAT 5 or 5E printed on the cable. If you are using stranded-wire, the cable is not supposed to be more than about 10 feet long, although I have seen longer ones that worked OK. Fluorescent lights, etc. can also cause packet corruption/retransmission. A bad network adapter can cause it.

All of your network settings look correct; however, I would suggest stripping the network configuration down to the bare minimum and concentrate on just two of the computers to troubleshoot the network: Client for Microsoft networks, Adapter, NetBEUI, and File and printer sharing. Leave all of these items at their default settings. Assign share names to drives other than the default of C$ (C$ won’t work from other PCs).

It appears that you have one of five problems: a bad cable, a bad or inoperative network adapter, a bad hub, or corrupted network components or drivers (if the computers can ping themselves, then the TCP/IP stack--drivers, etc.--is working, plus you have uninstalled and reinstalled everything). I have listed these items from the most to the least likely. I would verify that I had a good set of straight-thru cables and hub by connecting them between two computers on an operating network. Note: most hubs have regular ports and an uplink port. Be sure you are plugging the cables into regular ports. Also, many hubs/switches share regular port 1 with the uplink port. If PCs, etc. are connected to both ports, neither will work. If the cables and hub test good, the problem is most likely a bad network adapter or a network adapter that has a resource conflict. Do you see a solid Link LED and a blinking Activity LED on the back of the network adapters? Do the LEDs on the hub indicate a problem? Try pulling all unnecessary boards (e.g., soundcard) out of the computers while troubleshooting the network. Try moving the network adapters to other PCI slots. Avoid the two outer PCI slots. Slot 1 is usually shared with the AGP adapter and the slot at the other side is shared with an ISA slot, if there is one. Try substituting an adapter for another computer. If you have ISA boards in the computers, try implementing interrupt steering by enabling O/S is PnP aware, or something like that, in the CMOS Setup. While in the CMOS Setup, disable all motherboard resources that you do not need (COM ports, USB, etc.). Look for exclamation marks in Start, Settings, Control Panel, Device Manager and run the resource conflict troubleshooter. Examine interrupts and ports in detail by double-clicking Computer. I have found that conflicting network adapters do not always show-up with exclamation marks in the Device Manger and that windows thinks they are OK when they are not. Try forcing network adapters into using different IRQs and Ports Select the adapter in the Device Manager, Properties, Resources, uncheck Use Automatic settings… A lot of PCI boards will not allow these setting to be changed. Other will not allow an interrupt change, but will allow a port address change. Not all conflicts are caused by interrupts. This is especially true for network adapters. So, try changing the port addresses as well.

Open a DOS window on one of the computers and run:
C:\net diag
Is Microsoft Network Diagnostics currently running on any other computers on the network? N
Responding with N will make the computer the diagnostic server.
Run net diag on the other computer.
If it doesn’t work, try reversing the roles of the two computers. What happened? Larry

3. RE: I'm must be missing something simple for NetBEUI
Moesdeal Apr-22-01 02:49 PM
In response to message 0
Go to properties of TCP/IP. Select "specify an IP address". Enter the following address in the first computer, then in the next, and so on with any additional computers. Give them all the same subnet mask of; this will enable TCP/IP on the network. Then from the machine with the IP ending in ".2" go to a dos prompt and type, "ping" (make sure there is a space between ping and the IP) and see if you get a reply. You will have to reboot both machines after making this change.

| Home | Guides | How to | Reviews | Online Store | FAQ | Forums | Forum Archives |
| Links | News | Newsletter | About Dux | Advertising | Contact Info | Privacy |