Site Search

Site Info

Home » Forums » Forum Archives » Networking and Internet Sharing » Topic # 771

Missing Logon at Boot
jeff Mar-25-01 01:12 PM
In attempting to set up a 2 PC network I ran into a problem. One of the systems will not come up with a logon dialog box at boot up. I have tried to isolate the problem by removing the NIC and treating this as an OS problem instead of a networking problem. Is this line of thinking correct?

System with the problems is:
Dell 4100 PIII 933
128 MB RAM
30 GB HD, 20 GB Free
Win ME
IE 5.5

As I said the NIC has been removed and I’ve tried the following:
Larry’s FAQ at http://duxcw.com/faq/network/nopsswd.htm
MS KB article Q141858, almost the same as Larry’s FAQ
MS KB Q137361
MS KB Q148925
http://www.practicallynetworked.com/support/trblshot11.htm (When I thought it was a NIC problem)
I’ve also tried the built in MS Network Troubleshooter

I was following Larry’s How to Network Two Win 95/98 Computers. The setup went fine the other P90 w/ 16MB RAM and a Netgear FA311 NIC. Both TCP/IP and NetBEUI are installed and appear to be working fine. The system will ask to logon at boot. All I would like to do is share files between the two computers, no need to share an internet connection at this time.

When I called Dell they said they would not troubleshoot a network problem unless it was two Dell computers running through a Dell hub. When I said I would remove the NIC and they could treat it as a stand-alone Dell computer that would not logon, they said reinstall Win ME and probably lose any data on the system.

My questions, Has anyone come across this problem before? If an OS reinstall is required has anyone done that without losing data? I seem to remember doing a reinstall on some old Win95 systems by just dropping the CD in, and one of the options was to Reinstall/Update System Files. Does Win ME not offer this? Are there different/other steps to accomplish the same thing? I have the hard drive partitioned into 4 drives (C, D, E, F). The only thing on C is the operating system and any factory installed programs from Dell.

Any help would be greatly appreciated,

1. RE: Missing Logon at Boot
lbyard Mar-25-01 08:02 PM
In response to message 0
Weird problem... The registry change should have fixed it… I would check it. Have your tried both types of logons in the network configuration (Windows and the Microsoft client)? Either one of them will work for networking. Try deleting the C:\windows\*.pwl file(s), password file(s). Try deleting and reinstalling everything network. I don’t think it has anything to do with the network adapter. Larry

2. RE: Missing Logon at Boot
jeff Mar-25-01 09:44 PM
In response to message 1
Yes I tried both types of network logons, no luck. I deleted the (username).pwl file, when I rebooted Win ME did ask for a username and password. I entered my username and hit enter, not escape, for the password.
I also tried deleting everything network including TCP/IP and Dial-up Adapter, and deleted the modem out of device manager. This led to more problems. When I rebooted, the modem was detected and installed but when I went to Control Panel-Network-Add-Select Component Type there is no entry for Adapter. I expected to see:

Instead all I saw was:

Fortunatly I created a restore point and was able to go back to a point when Dial-up Adapter and TCP/IP were both visible under Network-Configeration.

At this point I'm back to where I started, no NIC installed and unable to get a network logon dialog box at boot. I'd rather not reinstall Win ME and risk losing data, so if you have any other ideas...

One last question, when I went to HKLM\Software\Microsoft\Windows\Current\Version\Network\Real Mode Net there was not an entry for AutoLogin. Should I create one with a value of 0? I've never added an entry to the registy, unsure how to do that. Same thing for the other registry key, there is no entry for Disable Password Caching.


3. RE: Missing Logon at Boot
lbyard Mar-26-01 04:59 PM
In response to message 2
Jeff, I would repeat deleting the *.pwl. When (and if Me) prompts for a password, enter one. You can always change it by clicking the password icon in the control panel. Suggest not doing that until the network is going. My computer logs on to my network using the Windows logon, does not prompt for the password, and does connect to my network. See http://duxcw.com/faq/network/logdomain.htm for details. Larry

4. RE: Missing Logon at Boot
jeff Mar-27-01 03:13 AM
In response to message 3
I deleted The *.pwl file and yes ME did ask to login. I entered a username and password then shutdown and installed the NIC. ME detected the card and seemed to install it correctly. I added NETBEUI and left it bound to the NIC and unbound TCP\IP from the NIC. I have Client for Microsoft Networks as the Primary Network Logon and have File and Printer Sharing for Microsoft Networks installed.
Then I ran into problems. When I go to Control Panel-Passwords-Windows Passwords there is no Microsoft Networking box to uncheck. Also I don't have NT installed so I don't know what to enter for the NT Domain or what password to use to logon to the NT domain account.
Two more problems came up today. If I go to Network Settings-Home Network Wizard- at the 4th screen, where it asks for Computer and Workgroup Names if I click next I get a BSOD with the following error message:
vserver(01) 00004d75 error:oe:0028:c175ce95. Also if I go to Control Panel-Passwords-and click on the Remote Administration tab I get a similar message. Ive never used the Home Networking Wizard or the Remote Admin tab before, so I don't know if these are really new, or old problems I just discovered.
I'm open for any suggestions, I don't know what else to try.

5. RE: Missing Logon at Boot
lbyard Mar-27-01 02:43 PM
In response to message 4
I believe that Microsoft Networking box applies when you are setup to login into Windows instead of the client. I have it for my Me. It is accessed by the Change Windows Password button. Anyway, you are logging-in and that is one part of what is required for a Windows peer-to-peer network. You can login to Windows or the client. Either should be sufficient to network. You should not be logging into an NT domain (Windows NT or 2000 server) and that check box should not be checked in the Properties of the Client for Microsoft Networking. I don’t use the Home Networking Wizard and haven’t yet—plan to, time permitting. Do it manually. Forget the remote administration. It is for another computer on the network to configure your computer… whatever; I haven’t played with it; you don’t need it. You can run both TCP/IP and NetBEUI at the same time, but let’s dwell on/keep it on NetBEUI as it is easier. Please review http://duxcw.com/digest/Howto/network/net2pc/intro.htm. Larry

6. RE: Missing Logon at Boot
jeff Mar-29-01 03:40 AM
In response to message 5
I found these articles in the MS KB.
Cannot Add Network Adapter in Network Properties

The summary exactly descibes the problem I'm having, and makes you wonder what MS is thinking:

You cannot add a network adapter (including the Dial-Up adapter) in Network properties in Windows Millennium Edition (Me).

This change was implemented to increase the stability of networking in general.

Apparently MS thinks if you can't add an adapter you can't cause problems? Anyway the recomendations did not work on my system. I'll continue trying.

A second article http://support.microsoft.com/support/kb/articles/Q272/9/91.ASP?LN=EN-US&SD=gn&FR=0&qry=q272991&rnk=1&src=DHCS_MSPSS_gn_SRCH&SPR=WINME
EXACTLY descibed the main problems I had trying to network. The article offers 3 possable fixes, a patch, a registry hack and a missing or damaged file. The file in question was present so I built the registry key as descibed (it was missing). This worked! Now both computers can see each other and I can transfer files both ways. The ability to add an adapter is still missing, but since everything I need is installed that problem goes on the back burner. I wonder if the missing registry key was intentional by MS?

Although things are much better, 2 new problems have appeared. First, on the ME system when I go to Network Settings the other computer does not show up. If I go to search and type in \\(computername) the other system shows up and seems to work fine. If I close Network Settings and open again the other system is missing again. Is there a setting that will force Network Settings to search/refresh automaticly?
Second when I clicked on the IE or Outlook Express icon, the dialog box asking to connect to our ISP came up immediatly. Now there is a 30-45 second delay and at the end of the session it won't auto disconnect. I'm not sure why this would be related to the registry fix, but since that was the only thing I changed it must be. Any ideas how to speed things up to its prior state?

Thanks for all your help,

7. RE: Missing Logon at Boot
lbyard Mar-29-01 04:47 PM
In response to message 6
Try mapping drives (http://duxcw.com/digest/Howto/network/net2pc/map.htm) and set the Client for Microsoft networks to Logon and restore network connections, which is the default. I am using Me and never noticed that one no longer manually add adapters in the Network configuration. I find the fact the Microsoft is limiting its products (making idiot software) at the expense of people who want to do things (and control things) as they did with older versions, most annoying. A network adapter can be manually added with Add/Remove Hardware in the Control Panel. Larry

| Home | Guides | How to | Reviews | Online Store | FAQ | Forums | Forum Archives |
| Links | News | Newsletter | About Dux | Advertising | Contact Info | Privacy |