Site Search

Site Info

Home » Forums » Forum Archives » Networking and Internet Sharing » Topic # 434

weird home network problem
flaz Dec-04-00 06:08 AM
I have a weird problem. I've setup an ethernet home network of 2
computers with the main purpose of sharing an internet connection.
I use a RJ-45 crossover cable. With a lot of work i managed to set
it to do what i want but i still got an awfull problem : the client is
limited to 7-8 kbits/sec >per file< downloading from the server. If i
download many files at the same time i can get speed up to
300kbits/sec (probably more) but every file transfer gets limited to 7-
8 kbits/sec. From the client to the server everything is fine.

The problem is not the ethernet card nor the cable since i've tried
many working ones and i always get the exact same problem. The
problem is not related to the internet since i've got the same low
speed downloading directly from the server harddrive using
networking neighborhood. The server is a PIII-600 running win 98
and the client is a AMD K6-200 running windows ME 4.90.3000
French. TCP/IP is the only protocol installed.

I need some clues ! Any help appreciated.

1. RE: weird home network problem
lbyard Dec-04-00 03:10 PM
In response to message 0
How are you connecting to the Internet? How much memory do you have in the client? What hard disk do you have installed on the client and how full is it? Do you have anything else connected to the cable going to the hard disk on the client; e.g., a CD-ROM? Do you have a bus master installed on the client? What chipset is on the client motherboard, or what is the make a model of the motherboard? See if local transfers speed-up with the NetBEIU protocol. Exactly what is the network configuration on each computer? You should be able to move 100 Mbytes between the computers in about 45 seconds. Larry

2. RE: weird home network problem
flaz Dec-05-00 00:13 AM
In response to message 1
The connection to the internet is a cable access running easily at 150kbytes/sec and i use wingate 3.0.5. The client has 64 megs of memory. The hard drive on the client is a quantum fireball of 6.4 gigs. It's connected to the primary master ide bus. I also have a 24x panasonic cd-rom reader connected to the secondary slave. The hard drive is split in many partition including two linux ones (which i can't run since i intalled win me). The three fat32 partitions has : C: total 1.49 Go Free 253 Mo D: 2.90 Go Free 530 Mo E: 124Mo Free : 0 (used exclusively for the windows swap file and the linux swap space.) The windows folder is on the C: drive. The motherboard of the client is a Asus TX97 with the intel 430TX chipset. The speed with the NetBEIU protocol is a lot better than TCP/IP but not as fast as you told me. A file of 244Mo took exactly 5min so it's about 833 kbytes/sec.

Network configuration

server running Windows 98 4.10.2222 A

local network ethernet card
Adress :
subnet mask
Dns: of the provider
no gateway
no wins resolution

network card used for internet access
automatic getting of IP
Dns: of the provider
no gateway
use DCHP for wins resolution

Client running windows ME

subnet mask
(automatic getting of IP works the same)

default gateway
dns server
no wins resolution

both boxes have a legal network name and the same workgroup

I'm not sure what a bus master is.

Thank you for your help, i think we're on the right track!


4. RE: weird home network problem
lbyard Dec-05-00 06:24 PM
In response to message 2
I would start by putting the Windows swap file back in C:\windows and making sure it is not set for read only. Larry

5. RE: weird home network problem
flaz Dec-05-00 11:52 PM
In response to message 4
Done. It didn't made any difference.

6. RE: weird home network problem
lbyard Dec-06-00 05:08 PM
In response to message 5
What do the network adapter LEDs tell you? Are they running at 100 Mhz and full duplex? Run msconfig and temporarily disable the autoexec.bat and config.sys files and reboot. Run it again and try disabling Startup; win.ini load, run; etc. The Intel chipset drivers are at ftp://ftp.asus.com.tw/pub/ASUS/misc/utils/intelinf.zip. Larry

7. RE: weird home network problem
flaz Dec-07-00 07:05 AM
In response to message 6
The LEDs are acting normal, blinking when data is being transmitted and light up to show connection. I've tried to disable all the config files in msconfig without success. I've checked the drivers of the chipset but they were ok. I've also flashed the BIOS for the latest version available, no changes.

But i've noticed something for the first time. When i boot up, before the "Starting windows..." the bios tell me that he assigned an irq to my network adapter and he always asign the same irq to the 'serial port controller'. I can't change the irq setting of the ethernet card in windows and i don't see no such thing as a 'serial port controller' but if i change the irq of the PCI slot of my network adapter in the bios the 'serial port controller' irq follows the irq of the network adapter. Do you think this can have anything to do with my problem ? I've tried 3 completely different and working ethernet card and the result is always very identical, still always a very consistent download of 7.2kBytes/sec with TCP/IP.

I've got 100MHz and a 10MHz card, the server has a 100MHz whatever i do it don't influence my speed.

Thank you for your help, Larry, it is apreciated.


8. RE: weird home network problem
lbyard Dec-07-00 06:36 PM
In response to message 7
Fred, I have seen the serial controller problem a few times and have not always been able to get rid of it. It may be the USB controller (if the motherboard has one). Try disabling all motherboard resources you donít need (e.g., USB, COM ports) in the CMOS Setup. Pull the MODEM if you have one in the computer. Autodetect hardware. Remove any multiple instances of drivers that show-up in the Device Manager. Try moving the network adapter to another PCI slot. You may want to uninstall all networking components and try going through the Winsock procedures published a few days ago. But I do not see how the later would slowdown NetBEUI. There must be something in that clunker, and it might be obvious if I were there, causing this problem. Glad to help; wish I had. Larry

9. RE: weird home network problem
flaz Dec-08-00 05:38 AM
In response to message 8
my problem is solved !
It was a registry setting : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP\DefaultRcvWindow

it was set to something like 2200 when i should have been 372300 for cable access. I think it's maximum size of a packet being transmitted, determined by the reveiving computer.

It was a setting i must have changed a few years ago to gain some speed with my 33600 modem.

Thank you again for your help, Larry, i now know a lot more about network than i was, and i've learned a valuable lesson : don't fiddle with settings you don't understand, or keep notes !


| Home | Guides | How to | Reviews | Online Store | FAQ | Forums | Forum Archives |
| Links | News | Newsletter | About Dux | Advertising | Contact Info | Privacy |