DUX COMPUTER DIGEST

 

Site Search

Site Info

Home » Forums » Forum Archives » Disk Drives » Topic # 102

CD-ROM Drivers not loading
rjm2 Mar-09-01 07:49 PM
I am getting reading to install a new hard drive on an older computer and was following some of your excellent tutorials. The computer is running Windows 95 and I plan on installing Windows 98 on the new hard drive. I created a Windows 98 startup disk and copied the CD ROM drivers to the A disk. I modified the config.sys file as follows:


device=SLCD.SYS /D:mscd001
device=himem.sys /testmem:off
device=oakcdrom.sys /D:mscd001
device=btdosm.sys
device=flashpt.sys
device=btcdrom.sys /D:mscd001
device=aspi2dos.sys
device=aspi8dos.sys
device=aspi4dos.sys
device=aspi8u2.sys
device=aspicd.sys /D:mscd001

When the computer boots off the A drive a message is displayed that the Sony drivers are being loaded but right after that a message indicates that the drivers failed to load. Some message about ALL DRIVES ARE POWERED DOWN OR COMMUNICATION FAILED.

Am I missing a step in here?? Any help would be appreciated. Thanks.


1. RE: CD-ROM Drivers not loading
lbyard Mar-09-01 07:59 PM
In response to message 0
See if the Sony driver requires some flags; most don't. There may be a readme file or something like that on the Sony floppy. Which Sony do you have? Double check the cables and drive jumpers. Remove the following lines:
device=oakcdrom.sys /D:mscd001
device=btdosm.sys
device=flashpt.sys
device=btcdrom.sys /D:mscd001
device=aspi2dos.sys
device=aspi8dos.sys
device=aspi4dos.sys
device=aspi8u2.sys
device=aspicd.sys /D:mscd001
Larry

2. RE: CD-ROM Drivers not loading
rjm2 Mar-09-01 08:28 PM
In response to message 1
Thanks for your response. I checked the config.sys file on the PC and changed the config.sys file on the boot disk to:

device=SLCD.SYS /D:mscd001 /B:300

The driver seems to load without any errors now. But at the end a message reads "File not found". If I try to change to the E: drive (D: is RAM??)...not found. Do I need to change any other files like autoexe.bat?

Thanks, Rich


3. RE: CD-ROM Drivers not loading
rjm2 Mar-09-01 08:52 PM
In response to message 2
I can now access the CD-ROM. Adding the flag did work. Is safe to assume that as long as I can access the CD-ROM using the boot floppy that I will be able to intall Windows 98? Thanks, Rich

4. RE: CD-ROM Drivers not loading
lbyard Mar-10-01 03:34 PM
In response to message 3
LAST EDITED ON Mar-10-01 AT 03:38 PM (GMT)

The file that isn't found is probably being specified in a line after the Sony CD-ROM driver. I like to use a Startup floppy made with the Manual method described at http://duxcw.com/digest/Fromshop/software/windows/startup/startup.htm and http://duxcw.com/digest/Howto/software/windows/winme/startup/page4.html. That gets rid of the troublesome RAM disk that Microsoft uses in a stock Startup floppy. Larry


5. RE: CD-ROM Drivers not loading
rjm2 Mar-13-01 00:28 AM
In response to message 4
I used your instructions and was able to boot from the floppy. The CD-ROM drivers installed. Thanks for your help.
Rich

| Home | Guides | How to | Reviews | Online Store | FAQ | Forums | Forum Archives |
| Links | News | Newsletter | About Dux | Advertising | Contact Info | Privacy |